On 3/01/2012 10:11 a.m., Kinkie wrote:
> Hi all,
> here's a new interim merge proposal for the StatHist refactoring
> effort. This merge aims to close bug 3381 and advance a bit the
> general StatHist refactoring effort.
>
> What it does:
> - change the type used for StatHist counters to uint64_t (parametric
> as StatHist::bins_type)
> - change the index for StatHist bins to unsigned
> - bring stub_StatHist forward and actually use it, also to remove some
> objects from tests
>
> What crept in:
> - an initial effort for a StatHist unit test.
> - some src/Makefile.am cleanup
>
>
in StatHist.cc:
* StatHist::findBin() - float type is quite inaccurate. Can you use
double?
* StatHist::operator =() - rather than duplicating this code can you
make it inline?
in testStatHist:
* please define testStatHistEnum() or replace with a TODO.
Amos
Received on Tue Jan 03 2012 - 02:32:29 MST
This archive was generated by hypermail 2.2.0 : Tue Jan 03 2012 - 12:00:11 MST